(none) imager-devel
/ help / lists / applications / search /
 

Re: Problem reading some TIFF images

From: Tony Cook (
10625@xyz.molar.is)
Date: Tue 05 Aug 2003 - 00:38:39 GMT

  • Next message: System Anti-Virus Administrator: "Disallowed attachment type found in sent message "Re: That movie""

    On Mon, Aug 04, 2003 at 04:57:19PM -0700, Derek wrote:
    > Hi,
    >
    > I am using Xp and Activestate 5.6.1 build 635. The program doesn't crash,
    > it just exits at that point. I tried to write a program in .Net today and
    > ran into a similar problem. I looked into that a bit and it maybe that
    > these are older tiffs which use a non-standard compression algorithm. I am
    > only interested in reading all of the metadata and not the actual image.
    >
    > Any help would be appreciated.

    Imager doesn't have an option to read just the meta data.

    Please try current CVS if you have a compiler (my windows box is at the
    dealer), and see if that fixes the problem.

    Otherwise you might want to consider Image::Info instead.

    If your image isn't sensitive please send me a copy and I'll give it a
    go when I get my machine back.

    Tony

    > >> Does Imager assume that tags are in a specific order? Is there anything
    > >I
    > >> can do to get this to work?
    > >
    > >You don't say which platform, or what happens to your programs when it
    > >reaches this point. Is it producing a GPF/segfault? Or is the read
    > >function just failing?
    > >
    > >It's possible that it's this issue:
    > >
    > > http://rt.cpan.org/NoAuth/Bug.html?id=1513
    > >
    > >which is fixed in current CVS.
    > >
    > >Tony



  •