(none) imager-devel
/ help / lists / applications / search /
 

Re: Problem reading some TIFF images

From: Tony Cook (
10544@xyz.molar.is)
Date: Mon 04 Aug 2003 - 23:15:30 GMT

  • Next message: Tony Cook: "Re: Problem reading some TIFF images"

    On Mon, Aug 04, 2003 at 09:29:59AM -0700, Derek wrote:
    > Hi,
    >
    > I am trying to read the tags from Tiff images. I went through the archives
    > and don't see anything that mentions this issue. I used the logging
    > feature and what I get is:
    >
    > [2003/08/03 22:29:40] log.c:35 0: Imager - log started (level = 1)
    > [2003/08/03 22:29:40] Imager.xs:125 1: Imager 0.41 starting
    > [2003/08/03 22:29:40] iolayer.c:980 1: io_new_fd(fd 5)
    > [2003/08/03 22:29:40] io.c:236 1: mymalloc(size 60) -> 0022A838
    > [2003/08/03 22:29:40] iolayer.c:992 1: (0022A838) <- io_new_fd
    > [2003/08/03 22:29:40] iolayer.c:828 1: io_glue_commit_types(ig 0022A838)
    > [2003/08/03 22:29:40] iolayer.c:829 1: io_glue_commit_types: source
    > type 0 (FDSEEK)
    > [2003/08/03 22:29:40] tiff.c:327 1: i_readtiff_wiol(ig 0022A838,
    > length -1)
    > File ends at this point.
    >
    > I read a different, smaller tiff file and the first 8 lines are the
    > same. In the smaller file the next line would be:
    >
    > [2003/08/03 22:35:13] tiff.c:118 1: i_readtiff_wiol: width=2032,
    > height=2640, channels=1
    >
    > So it looks like the read stops at the point where it reads the tags for
    > the dimensions. These files are 750k, but can be much larger.
    >
    > Does Imager assume that tags are in a specific order? Is there anything I
    > can do to get this to work?

    You don't say which platform, or what happens to your programs when it
    reaches this point. Is it producing a GPF/segfault? Or is the read
    function just failing?

    It's possible that it's this issue:

      http://rt.cpan.org/NoAuth/Bug.html?id=1513

    which is fixed in current CVS.

    Tony



  •