(none) imager-devel
/ help / lists / applications / search /
 

Re: GIF support

From: Tony Cook (
10299@xyz.molar.is)
Date: Thu 17 Jul 2003 - 00:21:18 GMT

  • Next message: 10373@xyz.molar.is: "Bounding-Box: pos-width value incorrect"

    Hi Reinhard,

    For GIF to be supported giflib needs to be at least installed on the
    machine used to build Imager, and the person who builds Imager needs to
    answer 'n' when asked if they really want to include GIF support.

    GIF support has both legal and technical issues, so it's possible they
    didn't include it deliberately.

    To check if Imager has been built with GIF support, try the following:

      perl -MImager -le "print for keys %Imager::formats"

    If the result includes "gif" you have GIF support.

    To get GIF support working you'll need to build Imager yourself, which
    will mean building giflib yourself (along with the libraries for any other
    formats you want supported.)

    Tony

    On Wed, Jul 16, 2003 at 02:05:23PM +0200, 10340@xyz.molar.is wrote:
    > Hello,
    >
    > I installed the lattest version of Imager on Perl v5.6.1 from Activestate on
    > a W2k machine.
    > Now I am trying to get informations from a GIF file. But it seems that GIF
    > is not supported,
    > because I get the error message "format not supported"? But in the
    > documentation of the
    > Imager I can find that GIF should be supported.
    > What do I wrong?



  •