(none) imager-devel
/ help / lists / applications / search /
 

Re: Mac and Imager

From: Arthur Bergman (
06598@xyz.molar.is)
Date: Tue 07 Jan 2003 - 14:49:48 GMT

  • Next message: Etienne Goyer: "Re: Tick label with Imager::Plot"

    On tisdag, jan 7, 2003, at 15:45 Europe/Stockholm, Ward W. Vuillemot
    wrote:

    > Sorry, I left the error Apache is throwing.
    >
    > libpng warning: Application was compiled with png.h from libpng-1.2.5
    > libpng warning: Application is running with png.c from libpng-1.0.12
    > libpng error: Incompatible libpng version in application and library
    >
    > I installed libpng onto Mac (1.2.5) via make into /usr/local/include
    > but libpng also exists as a Fink package as /sw/include thus 1.0.1.2
    >
    > I tried building without /sw/include, but the result is this:
    >
    > /usr/local/include/freetype2 doesnt exist or is unaccessible -
    > removed. /usr/include/freetype doesnt exist or is unaccessible -
    > removed. /usr/local/include/freetype doesnt exist or is unaccessible -
    > removed.
    >

    So you want to build all the things from /sw/include except png?

    Do you get this problem only from apache? I would guess some other
    module
    is built against a different libpng.

    Arthur



  •