(none) imager-devel
/ help / lists / applications / search /
 

Problem installing truetype support

From: Mike Depot (
00613@xyz.molar.is)
Date: Thu 15 Mar 2001 - 19:00:20 UTC

  • Next message: Arnar Mar Hrafnkelsson: "Re: Problem installing truetype support"

    I'm having a problem installing Imager with TrueType support on my RedHat 6.2
    machine. When I run the makefile, I get this:

    > # perl Makefile.PL
    > /usr/local/include/freetype doesnt exist or is unaccessible - removed.
    > done.
    > ungif: includes found - libraries found
    > tiff: includes found - libraries found
    > T1-fonts: includes not found - libraries not found
    > png: includes found - libraries found
    > gif: includes found - libraries found
    > jpeg: includes found - libraries found
    > TT-fonts: includes not found - libraries not found
    > ungif and gif can not coexist - removing ungif support
    > MakeMaker (v5.4302)
    > Writing Makefile for Imager::plugins
    > Writing Makefile for Imager

    When I installed freetype, I set it's prefix to /usr with

    > make setup CFG="--prefix=/usr"
    > make
    > make install

    This created "/usr/include/freetype2". I noticed Imager seemed to be looking for
    "/usr/include/freetype", so I make a symlink "/usr/include/freetype" pointing to
    "/usr/include/freetype2", hoping this would work, but it didn't. :-(

    Does Imager 0.37 support freetype 2.0, or do I need to install 1.3.1?
    If it does support 2.0, do you have any suggestions as to what may be wrong?

    Thanks,
    Mike Depot



  •